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This Cheat Sheet is to be used at UW-Madison as a quick guide to processing 
using the MestReC NMR software.  You may find more help at the MestReC homepage 
(www.mestrec.com) or by clicking on ‘help’ (F1) in the MestReC program. 
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1.  Opening data files 
 

Click on  in upper left corner or use <ctrl>I  or go to File -> Import Spectra ... 
 
•a dialog box appears in which you select the appropriate folder and then data set; 
•at the bottom of this box you can choose to have the program automatically detect 
what type of file your data is OR you can define this info, ie. Bruker, Varian, JEOL 
•if desired you can check the ‘create new document’ option which will open another 
window to put your data into ie. not use the one that is already open 
 
 

2.  Zero filling, Window functions and Fourier Transforms 
 

Click on the  icon or use <ctrl>T or go to Process -> Fourier Transform... 
 
•the first box defines the size of the FID in points, if you want to zero fill once double 
the amount of points, if you want to zero fill twice quadruple the number of points and 
so forth (this function adds zeros to the end of the FID and improves digital resolution) 
•the second box will allow you to do Linear Prediction (needed if the FID is truncated) 
•the third box will allow you to apply a window function to your data, check mark the 
box and then click on Set Function.  You can choose from: 
  Exponential multiplication (ie. Line broadening, for 1H 1D we typically 
use a ‘matched filter’ = 1/AQ, for 13C 1D we use between 0.5 Hz and 3.0 Hz) 
  Gaussian 
  SineBell 
  SineSquare 
  FirstPoint 
 if you would like to see what the window function is doing to your spectrum, 
check the interactive box (won’t need to FT after this) 
•the protocol box is not important for 1D data (can leave ‘none’ in the box) 
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•the Quadrature box will be checked (OK for 1D data) 
•check the Drift Correction box to remove the 0Hz center glitch and set the baseline to 0 
 
Once you are satisfied with your choices in the above boxes, click on Apply along t1 
and your options will be applied to the data and the FID will be transformed.  If you 
had used interactive mode, when applying the window function, click on Cancel, since 
your data is already FTed. 
 
 
 

3.  Changing the vertical position of the spectrum or FID 
 
•put the cursor over the scale on the right hand side of the spectrum and a hand icon 
will appear, click left mouse button and then drag up and down -> the spectrum will 
move up and down 
OR: 
•put the cursor over the baseline of the spectrum and the hand icon will appear, click 
left mouse button and drag up and down -> the spectrum will move up and down 
 
 

4.  Increasing/decreasing peak intensities 
 

•click on the  or  icon on the toolbar at the top of the spectrum;  will 

increase the intensities,  will decrease the intensities 
OR: 
•use the + and – buttons on the keyboard to increase and decrease intensities, 
respectively 
•if your middle mouse button is a scroll wheel, you may use that – scrool up to increase 
intensities, scroll down to decrease intensities 
 
 

5.  Phasing the spectrum 
 

•click on the  icon in the toolbar and a ‘phase correction’ dialog box appears 
•all the way to the left of the spectrum there will be a red line with which you define a 
pivot point, so drag the red pivot line to a large peak either on the right or left side of 
the spectrum OR click on ‘biggest’ in the dialog box to put it on the biggest peak in the 
spectrum 
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•with the cursor over the ‘phase correction’ dialog box, click left to correct the zero 
order phases -> the peaks surrounding the pivot line (a red 0 will appear by the cursor 
reminding you that you’re doing zero order phases) 
•with the cursor still over the ‘phase correction’ dialog box, click right to correct the 
first order phases -> the peaks on the opposite side from the pivot line 
•remember to increase the intensity of the spectrum enough to make sure the phase 
corrections are adequate 
•when you are satisfied with the phase corrections click OK in the dialog box 
 
 

6.  Referencing the spectrum 
 

•Click on the  icon.  The cursor becomes a cross with the word ‘TMS’ below it. 
•line the cross up with the peak that you want to reference to and click the left mouse 
button (it is helpful to expand on this peak first) 
•a ‘reference’ dialog box appears that lists numerous NMR solvents including TMS 
•choose the solvent to which the peak belongs and then hit OK 
-> the spectrum should now be referenced! 
 
 

7.  Zooming in on regions of the spectrum 
 

•click on the  icon in the toolbar and the mouse will change to a magnifying glass 
•point to either the left or right hand side of a region you want to expand, click left and 
scroll over the desired region (the region will be highlighted) 
•as soon as you let go of the mouse button the region will expand 

•for manual zoom: click on the  icon in the toolbar and enter the ppm values of the 
region you want to expand (it can also be in Hz, points or sec) 
 
•to view other regions in the spectrum, click on the scale at the bottom of the spectrum 
and drag left or right depending on where in the spectrum you want to go 

•to go back to the full view of the spectrum, click on the  icon in the toolbar 

•enlarging/collapsing from the center:  the  icon will enlarge the spectrum by a 

certain amount from the center (click on it several times for a good expansion), the  
icon will collapse the spectrum (clicking on it enough times will eventually display the 
full spectrum) 
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8.  Baseline correction  
 
There are several choices for baseline correction and it is up to the user to decide which 
one they prefer.  The recommended ones described in part a) and in part d) 
 
 a)  Polynomial Baseline Correction ... brings up a dialog box with this name and 
gives you the option of applying anything a polynomial with a function of order 
anywhere from 0 to 7 (anywhere between 5 and 7 is recommended).  Leave the filter 
value at 2 and don’t check ‘trigonometric function’, unless you want a trig function 
applied instead of a polynomial series. 
 
 b)  Full Auto...applies what the program thinks is best for a baseline correction.  
This is not recommended, since it seems to somewhat convolute the baseline. 
 
 c)  Baseline Correction with Bernstein Polynomials...  This basically gives you the 
option for choosing a polynomial with the order between 2 and 20, similar to option a). 
 
 d)  Multipoint Baseline Correction...A dialog box appears in which you may 
choose between a polynomial, linear or spline function.  A polynomial function of order 
3, 4 or 5 is recommended.  Then click on the ‘pick’ box and in your spectrum manually 
pick baseline points.  With the red line you will observe the program choose 
appropriate functions to fit your baseline.  This is a good method as long as you pick 
many points, which are true baseline points.  (This is most similar to the NUTS ‘FB’, Fit 
Baseline subroutine) 
 
 e)  Manual Baseline Correction.... A dialog box appears in which you can enter 
constants for the polynomial function.  At the same time a red line appears through the 
baseline of the spectrum.  As you increase/decrease values associated with each part of 
the function (x, x2, x3, etc.) the red line will reflect the values entered.  The goal is to fit 
the red line as closely to your baseline as possible. 
 
•after the baseline correction is applied, you will notice that the FT and phasing icons 
are shaded out, since they are no longer needed for this data set 
 
 
 

8.  Peak picking 
 

•click on the  icon to the right of the TMS icon, if you click on the arrow a list of 
options will appear 
•the first option ‘peak picking’ gives a cursor that looks like a couple of picked peaks 
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•scroll to the set of peaks that you want picked and with the left mouse cursor 
depressed go over the desired peaks.  In this way the ‘threshold’ level can be different 
for different regions of the spectrum. 
 
•the second option ‘list peaks’ will open a dialog box in which all the picked peaks are 
listed; each peak has an index number, with ppm, Hz, points and height listed for each 
peak; the list may be exported to a file and individual peaks may be deleted from here 
(a very nice way of managing the peak list) 
 
•the third option ‘peak by peak’ allows you to pick peaks one at a time and helps you 
determine where the height of each peak is, since scrolling over the peaks highlights 
each one with a red line and the chemical shift listed at the top 
 
•the last option allows you to delete all the picked peaks 
 
 
 

9.  Peak integration 
 
•make sure you’ve applied some kind of baseline correction before attempting this 

•choose the  icon in the toolbar menu, the integration icon, which includes three 
options 
•the first option allows you to select peaks for integration; the cursor will change to an 
arrow with an integral symbol next to it;  with the left mouse button depressed scroll 
over the peak that you would like integrated 
 
•the second option OR right clicking over the integrated peak brings up the integration 
manager; this integral can now be manipulated by moving it up or down, increasing it’s 
size and changing the tilt and slope of the integral; play around with the resize arrows 
to see what each one accomplishes 
•in the integration manager dialog box there are two ‘navigate’ arrows, which allow 
you to move to the next integrated peak to manipulate the integral; individual integrals 
may also be deleted in this way 
•the value for an integral may be entered under ‘reference’ in the integration manager 
dialog box and will scale all the other integrated peaks accordingly 
•a label may be assigned to each integrated peak by right clicking over the integrated 
peak and choosing ‘assign label’ 
•the ‘list integrals’ option brings up a dialog box with the integrals listed by ppm and if 
labels were chosen they will be listed; each integrated peak may be colored a different 
color by checking the ‘fill’ box and choosing a color in the right most column 
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10.  Adding notes to the spectrum 
 

•click on the  icon and a text dialog box appears in which you can set the font and 
the text size 
•enter the text that you want to appear next to your spectrum 
•to add another line to this ‘text box’ press <ctrl>+enter  (one of the more difficult 
features to get used to) 
•once you’re done editing and writing what you want in the text box click ‘OK’ 
•you can drag this box to wherever you desire next to your spectrum 
•right clicking on the box will give you the option to edit the comment or delete the 
comment 
 
 

11.  Printing the spectrum 
 
•there is a print preview option, which is nice because you can see exactly what will be 
printed on the screen; get to it by choosing  File -> Print Preview OR by clicking on the 

 icon 

•click on the  icon to print the spectrum making sure you have chosen all the 
appropriate options (correct printer, page numbers, no. of copies) 
 
 

12.  Saving the spectrum 
 

•click on the  icon to bring up the save dialog box 
•choose the appropriate folder in which you want the spectrum saved (make sure it is 
under the P:\temp directory if you’re in the routine lab, or to your floppy, CD or zip) 
•give the spectrum a name and make sure you save it as a MestreC file (*.mrc) 
 
 

13.  Displaying multiple spectra 
 
•multiple spectra may be opened at the same time.  This may be done by either 
displaying them in separate windows within the MestreC program or displaying them 
within the same window. 
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•opening documents in the SAME window: after opening and manipulating the first 

spectrum click the  icon and select the next data set.  Make sure that the ‘create 
new document’ box is not checked.  The new fid will open in the same (blue) window 
and initially be the same size as the first data set.  Each data set has its own frame and 
one can go back and forth between data sets by clicking on the different frames. (offset 
the two data sets by dragging one to a new position to tell which one is which) 
•opening documents in DIFFERENT windows: after opening and manipulating the first 

spectrum click the  icon and select the next data set.  Make sure that the ‘create 
new document’ box IS checked.  This will open another (blue) window with the newly 
opened data set.  To move between data sets, select the different tabs in the lower left 
corner. 
 
 

14.  Stack plotting spectra 
 
•open the first data file in the group of files that you wish to stack plot and process as 
desired (the way you will want all the spectra for the stacked plot to be processed) 
•go to Options -> Show script editor (the Script editor box appears) 
•select Read from the buttons on the right side of the Script editor, the commands that 
you had just applied to your data set will appear in the screen 
•select Save and save the *.txt file to a directory where you can find it later (this saves 
the macro that you will run on all the data files for the stack plot) 
•go to Window -> Close and close the current spectrum (or your stacked plot will have 
an additional spectrum) 
•go to File -> Import multiple spectra and click on the +Add File... box 
•select the files that you would like to open for the stacked plot one by one OR go to the 
Files Mask box and click on the box to the right marked with ‘...’.  If the files all have the 
same name, but different suffix, a ? can be used as a wild card.  Enter the file name and 
wild cards where appropriate and click on the Add Group box.  The files you want 
opened will appear in the window above. 
•to run the script/macro that you had just created, click on the ‘...’ box by the Script box 
and find the *.txt file that you had saved 
•for a true stacked plot you will need to check the ‘Import all files in the same window’ 
box and all of the files will be processed and placed in the same blue window 
•the 1D data sets will not automatically be placed as a stacked plot, but instead will be 
arranged in a certain number of rows and columns depending on how many were 
opened; they will also not automatically be scaled to absolute values 
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14. a) Rearranging the multiple opened 1D data sets 

•from the icons at the bottom of the screen, click on the  icon and choose ‘Stack 1D 
Spectra’  ---> all your spectra should now appear stacked but the scaling of each may be 
off 
•select all spectra by using <ctrl>E or by going to Edit -> Select All Spectra and then 

click on the  icon at the top 
 
•now correct intensities on the first spectrum (the one you want all others to be scaled 
to) and follow the scaling/absolute value directions below 
 
•the last spectrum in the stack may not be visible because the presence of the ppm scale 
hides the spectrum, so select this spectrum and then right click on the scale and change 
the size of the scale box (to 9mm or less).  You may still need to find the spectrum, by 
enlarging the size of this individual spectrum box until the spectrum is visible.   Then 
scroll over the spectrum and when the ‘hand’ mouse appears, move the spectrum to an 
appropriate position above the scale.  Resize the box that holds this spectrum either 
back to its original size or an appropriately chosen size. (this is a pain) 
 
•to adjust the angle at which the stacked spectra appear, first select all spectra (<ctrl>E) 

and then go to the  icon at the bottom and choose ‘Stack Options...’  Enter a 
different value for the angle and then click OK to see what it does with the spectra. 
 
•to adjust the y-scaling/spacing between the different spectra in the stack plot, you 
need to do this manually, one spectrum at a time 
 
•to adjust the box sizes that the spectra are in, select all the spectra and while holding 
the shift key down use the Up/Down arrow keys on the keyboard, which will enlarge 
or minimize all the spectral boxes. 
 
 

14. b) Scaling all the spectra to the first in the series (absolute value): 
 
According to the authors of MestreC this is not possible in a direct manner.  The 
following will do an equivalent: 
•make sure you put all the spectra in the same document or window as described 
above 
•go to Tools -> Arithmetic and all the spectra within this window will be normalized to 
the first spectrum.  Then just close the dialog box.  (to test if this really works you can 
change the intensity of the first spectrum and then go to Tools -> Arithmetic) 
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15.  Processing VNMR arrayed fids (such as a set of DEPT spectra) 
 

•open the fid that contains the array by clicking on the  icon and choosing the 
appropriate data set 
 

•fourier transfer the data as you normally would by clicking on the  icon and 
applying an appropriate window function, then select ‘transform along t2’ 
(at this point you may get a warning message if the size of the FT is greater than 32K, if 
so switch to the contour plot mode and proceed) 
 

•click on the show traces button:    
 
at this point you may select which ‘slice’ in the array you would like to view by using 
the ‘slices selector bar’  (chose different horizontal slices, since the vertical ones don’t 
make sense in this pseudo 2D data set) 
 

•phase this spectrum as you normally would by clicking on the  icon (see p.2) 
 
•to be able to view the arrayed spectra as independent spectra, right click on the visible 
spectrum and go to ‘Extract Row’ -> ‘Extract All Rows to a New Document’.  Voila! 
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MestReC 2D Cheat Sheet 
by Monika Ivancic  July 15th, 2005 

 

16.  Magnitude 2D spectra (COSY, gHMBC, ...) 

•import the spectrum by clicking on the  icon  (select the file named fid if this is 
Varian data or ser if it is Bruker data) -> you will see an array of FIDs that makes up the 
2D experiment 

•click on the  icon to FT along the direct dimension (t2).  If you wish to zero fill 
then chose an appropriate number of points in the ‘size’ box.  Chose a non shifted sine 
bell window function, under ‘Set Functions’.  Then click on apply along t2 to get an 
interferrogram with the X-axis in ppm (one dimension is FTed while the indirect FID 
still exists). 

•click on the  icon a second time and chose an appropriate window function (a non 
shifted sine bell should work).  If you wish to zero fill you may set the size to a larger 
number of complex points. Also, check the magnitude selection box and then click apply 
along t1.  Your spectrum should appear with a ppm scale in both dimensions. 
•you can use the +/- buttons to set the threshold level and the zoom buttons to expand 
certain regions  (see the 2D Spectral Manipulations section for more info) 
 

17.  Phase sensitive 2D spectra (NOESY, ROESY,...) 

•import the spectrum by clicking on the  icon  (select the file named fid if this is 
Varian data or ser if it is Bruker data) -> you will see an array of FIDs that makes up the 
2D experiment 

•click on the  icon to FT along the direct dimension (t2).  If you wish to zero fill 
then chose an appropriate number of points in the ‘size’ box.  Chose a 90º shifted sine 
bell window function, under ‘Set Functions’.   Under protocol, none should be selected 
and the Invert box should be checked along with the Quadrature check box.  Then click 
on apply along t2 to get an interferrogram with the X-axis in ppm (one dimension is FTed 
while the indirect FID still exists). 

•click on the  icon a second time and chose an appropriate window function (a 90º 
shifted sine bell should work).  If you wish to zero fill you may set the size to a larger 
number of complex points.  Make sure that under Protocol ‘Hyper’ is selected and that 
the Invert box is checked along with the Quadrature box and the HyperPhase box.  
Then click on apply along t1.  Your spectrum should appear with a ppm scale in both 
dimensions. 
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17.  a) Real time 2D phase correction: 

•to show 1D traces at the top and left side of the spectrum click the  icon on the 
vertical toolbar on the left and select ‘show traces’ -> the 1D traces should appear  (these 
may be manipulated using the last 8 icons on the vertical toolbar on the left) 

•click on the  icon and then choose f2 in the dialog box that opens (f2 will be the 
active dimension for the phase correction) 

•now click on the  icon at the top of the screen and choose a row that has an intense 
peak in the upper right corner/side of the spectrum 
•then move the pivot point (red line) in the top 1D projection onto the intense peak and 
use 0 order phase corrections to correct the phases (click left and scroll up & down over 
the phase correction dialog box).  This corrects the phases of the entire 2D spectrum and 
may take some time to see the changes take place. 

•now with the  icon choose a row with an intense peak in the lower left corner of 
the spectrum.  Correct the phases using 1st order phase corrections (click right and scroll 
up & down over the phase correction dialog box).  Again, this applies the phase 
corrections to the entire spectrum and may take some time to ‘catch up’ between 
adjustments. 
•use the same procedure to correct the phases in the indirect dimension, choosing f1 in 
the phase correction dialog box. 
 

17.  b) 2D phasing using 1D slices (similar to VNMR protocol): 

•click on the  icon to get up the dialog box.  Select the f2 dimension and then click 
on the ‘2D phasing using 1D’ box and another dialog box appears (called ‘2D phasing’). 

•click on the  icon at the top of the screen and choose a row that has an intense 
peak in the upper right corner of the spectrum.  Then click on  the ‘add trace’ box in the 
dialog box and the trace should appear in this 2D phasing dialog box. 
•Pick another trace that contains an intense peak in the bottom left corner of the 
spectrum.  Then click on the ‘add trace’ box and this trace will appear in the bottom half 
of the 2D phasing dialog box. 
•set the pivot by positioning the white vertical line in the 2D phasing dialog box over 
one of the intense peaks.  Use 0 order phases to correct the phases under the pivot point 
(click left and scroll up & down over the dialog box) and 1st order phases to correct the 
peaks on the opposite side of the spectrum (click right and scroll up & down over the 
dialog box). 
•the spectrum that is activated in the 2D phasing dialog box will have a green border 
around it, while the spectrum that is deactivated will have a red border around it.  The 
icons at the top of the dialog box (+/-, zoom) will work in the activated spectrum. 
•repeat this procedure for the f1 (indirect) dimension 
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18.  Phase sensitive echo-antiecho 2D spectra (gHSQC, ...) 
 

•import the spectrum by clicking on the  icon  (select the file named fid if this is 
Varian data or ser if it is Bruker data) -> you will see an array of FIDs that makes up the 
2D experiment 
 

•click on the  icon to FT along the direct dimension (t2).  If you wish to zero fill 
then chose an appropriate number of points in the ‘size’ box.  Chose a 90º shifted sine 
bell window function, under ‘Set Functions’.   Under protocol, none should be selected 
and the Invert box should be checked along with the Quadrature box.  Then click on 
apply along t2 to get an interferrogram with the X-axis in ppm (one dimension is FTed 
while the indirect FID still exists). 
 

•click on the  icon a second time and chose an appropriate window function (a 90º 
shifted sine bell should work).  If you wish to zero fill you may set the size to a larger 
number of complex points.  Make sure that under Protocol ‘EchoAntiecho’ is selected 
and that the Invert box is NOT checked while the Quadrature box and the HyperPhase 
box are.  Then click on apply along t1.  Your spectrum should appear with a ppm scale in 
both dimensions. 
 
•this spectrum will have to be phased, so follow the procedure described above (17a 
and b)  for phasing 2D data 
 
 

19.  Manipulating 2D data in MestreC 
 

19. a) Referencing the 2D spectrum 
 
•Zoom in on the peak that you want the spectrum referenced to 

•Click on the  icon, which makes the cursor change into a cross with the letters 
TMS written in black below it 
•Then click on the center of the peak that you want to use as a reference 
•a ‘2D reference’ dialog box appears in which you may enter the specific chemical shift 
for the peak or click on the box to the right of the ppm entering box to get a list of 
solvents to choose from.  Enter the correct solvent or ppm in both the F1 and F2 
dimensions and then click OK. 
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19.  b) Displaying positive vs. negative contour levels 

•The  icon will allow you to display the positive contours in a 2D spectrum 

•The  icon will let you display the negative contours and you may toggle these 
two options on and off, displaying either positive or negative contours, neither or both 
 
 

19.   c) Increasing/decreasing intensity levels 

•Similarly as with 1D data, use the  and  icons to lower and raise the view of 
contour or intensity levels in a 2D data set 
•You may use the – and + on the keyboard to do the same 
•If your middle mouse button is a ‘scroll wheel’ moving it up will go lower down on 
the contour display while moving it down will go higher up on the levels display 
 
 

19.  d) Zooming in on regions 

•Select the  icon, which changes the mouse to have the same symbol 
•Then in the spectrum select the region you want to zoom in on by clicking the left 
mouse button and boxing in the peaks that you want zoomed 
•The nice thing about this is that you may start in any corner of the region you want 
zoomed 
•Once zoomed, you may view other areas of the spectrum by moving the mouse over 
the ppm scale, click+hold the left mouse button and scroll up and down (vertical shifts) 
or left and right (horizontal shifts) 
 
 

19.  e) Contour/intensity display options 

•Under the  icon, several choices for 2D data display exist: 
  •Fast Plot – shows an intensity display of the 2D data 
  •Contour Plot – shows the 2D data in contour levels 
  •Filled Contoured Plot – shows a combination of contours and intensities 
  •Stacked Plot – will show the 2D data as a stack of 1D spectra and will 
bring up a ‘plot angle’ dialog box in which you may change the angle of the stack plot 
  •White Wash – brings up the same ‘plot angle’ dialog box and also 
removes the contours that are under and behind displayed peaks (similar to NUTS 
white wash) 
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19.   f) Using traces/projections along the 2D axes 
 

•Click on the  icon to have a horizontal trace above the 2D spectrum and a vertical 
trace to the left of the 2D spectrum 

•Choosing the 2nd option under the  icon gives you a choice of the slice number in 
the 2D data set that you would like displayed as the trace (chose this from the dialog 
box) 

•Choosing the 3rd option under the  icon allows you to select specific 1D data sets 
(previously processed and saved) to be used as traces above and to the left of the 2D 
spectrum 
 
 

19.  g) Positioning/intensity of the traces 
 
•there are 8 icons that deal with this, most of them are self intuitive 

•to change the intensity/peak height of the traces use the  and  icons 
associated with the vertical or horizontal trace 

•to change the position of the trace use the  or  icons associated with the 
appropriate trace 
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